: Coloque seu e-mail aqui para receber GRATUITAMENTE o meu EBOOK - - 10 Funções que podem fazer de você um perito em EXCEL
Excel na Web

18 Função PROCV Como usar no Excel


Como usar a Função PROCV no Excel. Aprenda os segredos da fórmula mais usada no mundo. A realização de pesquisas de dados é uma das operações mais executadas no Excel. Existem diversas maneiras de encontrar informações ou realizar uma pesquisa no Excel. A mais utilizada é a Função PROCV. É importante destacar que PROCV quer dizer procurar verticalmente e não procurar valores, como muitos podem pensar. Isso porque, a Função PROCV, irá percorrer uma coluna para pesquisar o valor procurado e retornar a informação desejada. Mas, de que forma isso acontece?



Continue lendo este tutorial de Excel básico e aprenda: 
  • Como fazer a Função PROCV no Excel. 
  • Como usar a Função PROCV para pesquisar valores no Excel 
  • Como fazer PROCV passo a passo.

Como funciona a Função Procv

A função PROCV possui 3 parâmetros obrigatórios (Valor_procurado, matriz_tabela e num_índice_coluna) e 1 parâmetro opcional (0 ou 1) que vai aparecer de acordo com a situação.

Sintaxe: PROCV(valor_procurado;matriz_tabela;núm_índice_coluna;procurar_intervalo

  • valor_procurado: o valor a ser procurado na primeira coluna de dados da tabela. Pode ser um valor ou uma referência.
  • matriz_tabela: Uma ou mais colunas de dados. Os valores na primeira coluna de matriz_tabela são os valores procurados por valor_procurado. Os valores podem ser texto, números ou valores lógicos.
  • núm_índice_coluna: o número da coluna em matriz_tabela a partir do qual o valor correspondente deve ser retornado. Um núm_índice_coluna de 1 irá retornar o valor da primeira coluna em matriz_tabela; núm_índice_coluna de 2 vai retornar o valor da segunda coluna, e assim por diante.
  • procurar_intervalo: um valor lógico que dirá se PROCV irá localizar uma correspondência exata ou aproximada. Utiliza-se o numeral 0 para exata e 1 para aproximada.

Como usar o PROCV passo a passo

Sempre que precisar usar a fórmula procv você deve pensar da seguinte forma:

=PROCV(célula onde irei digitar o valor a ser pesquisado; intervalo de células que contém os dados; nº correspondente a coluna que irá retornar a informação; correspondência exata ou aproximada)

No exemplo abaixo ao digitar o Código do produto, a tabela de resultados deverá retornar a descrição do produto na célula que contém a fórmula PROCV.

Observe como o Excel irá interpretar a fórmula:

=PROCV (Procure o código B002 contido na célula A15, na tabela de produtos A1:C11, e retorne o valor correspondente da coluna 3 da tabela, mas apenas retorne um valor se você encontrar o código exato B002 na tabela de produtos, caso contrário retorne um erro)


A célula C15 possui a seguinte fórmula: = PROCV(A15;A1:C11;3;0) ou seja:

=PROCV( : Inicio da função

A15: é o valor procurado. Neste exemplo, o código do  produto. Você pode digitar A15 ou ir até a célula e selecioná-la.

A1:C11: é a Matriz_tabela ( tabela desejada ). Você deve selecionar todo o intervalo da tabela onde as informações estão localizadas. Outra alternativa seria informar o nome que você aplicou ao intervalo de pesquisas, mas isto será explicado em outro tutorial.

3: núm_indice_coluna (Coluna Desejada). Você deve informar em qual coluna está localizada a informação procurada. Sabendo que a tabela produtos tem três colunas e, quer-se retornar o preço do produto, deve-se digitar 3 (terceira coluna). Procure não considerar os títulos das colunas (A,B,C...), observe apenas qual o número da coluna na tabela que contém a informação.

0: [procurar_intervalo] (Valor Lógico - Verdadeiro ou Falso). O valor lógico permite retornar resultados aproximados ou exatos em sua planilha. O valor 0 é equivalente a Falso e irá retornar os valores exatos; já o valor 1, é o mesmo que verdadeiro e irá retornar resultados aproximados.

Na célula B15 você pode observar a fórmula:  =PROCV(A15;A1:C11;2;0)

Note que a única diferença é o número da coluna (2), ou seja, a coluna correspondente a descrição do produto.

Já no exemplo abaixo, ao digitar o código do produto o PROCV retorna a descrição do produto correspondente:


A célula B15 contém a seguinte fórmula: =PROCV(A15;$A$1:$C$11;2;0) que quer dizer:

Procure o valor contido em A15; no intervalo de células $A$1:$C$1; e retorne o valor correspondente a coluna 2, mas apenas retorne um valor se você encontrar a correspondência exata, caso contrário retorne um erro.

OBS: Caso o Excel não encontre nenhum valor ele irá mostrar a mensagem de erro: #N/D. Este problema é facilmente corrigido utilizando a Função SEERRO do Excel.

Leitura recomendada:

Como corrigir o erro #N/D de uma PROCV no Excel

Agora que você ja sabe fazer Procv no Excel aprenda a fazer Procv ao contrário, ou seja da esquerda para a direita:

Como fazer PROCV ao contrário no Excel

O PROCV é uma das fórmulas para Excel mais utilizadas nas planilhas. É uma fórmula bastante simples, mas suas aplicações são muitas, especialmente quando usada em conjunto com outras fórmulas, como SE, SOMASE entre outras. Recomendo que leia o artigo: Como usar  Função Se no Excel para imediatamente começar a elaborar fórmulas PROCV mais eficientes.

Para pesquisar em várias planilhas no Excel leia:


Para pesquisar no Excel usando dois ou mais critérios leia:


Para retornar todos os valores com PROCV no Excel leia:



Conteúdo VIP

Coloque o seu email abaixo para receber gratuitamente as atualizações do blog!


Clique aqui e faça o download da planilha utilizada neste tutorial de Excel

Ricardo Fialkoski é o fundador do blog Excel na Web. Trabalha com Excel há mais de dez anos desenvolvendo Soluções Avançadas em Excel e VBA.

Comentário(s):

18 comentários :

  1. Muito bom, claro e objetivo! Ricardo, tenho uma dúvida, como faço para aplicar o PROCV em uma planilha, onde preciso de 03 critérios para encontrar o resultado desejado?

    Ex: linha - x ; processo - y; tempo - z = descrição - xyz

    ResponderExcluir
    Respostas
    1. Boa noite Ygor, veja este tutorial: http://www.excelnaweb.com.br/2014/01/funcao-procv-com-duas-condicoes.html. Para tres condições é o mesmo conceito. Obrigado pela visita. Um abraço!

      Excluir
  2. Respostas
    1. Ola, obrigado! Aprender a usar a Função PROCV no Excel é muito importante e lhe abre muitas possibilidades.

      Excluir
  3. Olá Ricardo, beleza? Mestre eu gostaria de saber se é possível usar a fórmula PROCV para fazer pesquisas através dos nomes presentes na tabela, ou seja, digitaria "Fernanda" e apareceria as suas informações e não pelo código XXX, por exemplo, para visualizar os seus dados. É possível? Agradeço desde já e parabéns pelo trabalho!

    ResponderExcluir
    Respostas
    1. Olá é possivel sim, da mesma forma que você faz para procurar pelo código, o problema é que se estiver mais de uma ocorrencia para o nome pesquisado a Função PROCV irá mostrar sempre o resultado da primeira ocorrência. Abraços!

      Excluir
  4. Muito útil, muito obrigado. Parabéns pela didática.

    ResponderExcluir
  5. Preciso colocar a função procv em varias celulas da mesma coluna, como faço para não ter que ficar inserindo a formula na celula uma por uma?

    ResponderExcluir
    Respostas
    1. Ola, você pode usar a alça de preenchimento.

      * Digite a fórmula na primeira célula.

      * No canto direito da célula aparece um quadradinho destacado.

      * Posicione o mouse sobre esse quadradinho, até que ele assuma a forma de uma cruz

      *Então quando ele estiver assim, clique e arraste para baixo até onde deseja que as fórmulas sejam preenchidas.

      Abraços!

      Excluir
  6. Bom dia.
    Estou tentando fazer uma função PROCV, onde gostaria que o resultado fosse um código da tabela e não digitar o código e aparecer o nome do produto referente a esse código.
    Ex.: quero digitar o nome Borracha e na célula ao lado aparecer 01.0001.
    A B
    01.0001 Borracha
    01.0002 Caneta Esferográfica Azul
    01.0003 Cola
    01.0004 Copo descartável 200 ml (Pct)
    Na fórmula que estou digitando está ficando assim: =PROCV(C2;A1:B4;1;0), mas retorna #N/D.
    O que fazer para dar certo?

    ResponderExcluir
    Respostas
    1. Ola Mega Eventos, a Função Procv não funciona da direita para a esquerda. Sendo assim, você precisa inverter as colunas na sua planilha e retornar a coluna 2 da tabela A1:B4.

      A B
      Borracha 10.001
      Caneta 10.002
      Cola 10.003
      Copo 10.004

      Depois desta alteração use a seguinte fórmula:

      =PROCV(C2;A1:B4;1;0)

      Abraços!

      Excluir
  7. Muito obrigado, site extremamente util, estou me reciclando e esta sendo extremamente proveitoso.
    Muito obrigado!!!

    ResponderExcluir
    Respostas
    1. Opa LKDesign®! Que bom que estamos sintonizados com suas necessidades! :)

      Fico feliz por saber que gostou do blog e que este os conteúdos serão úteis para seus estudos!

      Grande abraço!

      Excluir
  8. Que site!! Top!! Vou tentar fazer com a dica de vocês!!!
    Obrigado!! Caso eu não consiga eu retorno.abraço

    ResponderExcluir
    Respostas
    1. Obrigado pelo elogio Vinicius! Aproveite todo o nosso conteúdo e qualquer dúvida deixe um comentário. Forte Abraço!

      Excluir
  9. Excelente didática !! Era o que eu procurava. acabei de economizar 500,00 de curso,rs.Valeu demais!!Muito obrigado por existir!!

    ResponderExcluir
    Respostas
    1. Muito obrigado! Que esse aprendizado te impulsione a ir cada vez mais longe e a ter cada vez mais sucesso! Abração!

      Excluir