: Coloque seu e-mail aqui para receber GRATUITAMENTE o meu EBOOK - - 10 Funções que podem fazer de você um perito em EXCEL
Excel na Web

10 Função SEERRO Como esconder erros no Excel


Como usar a Função SEERRO para corrigir erros no Excel. Conhecer as fórmulas e funcionalidades do Excel é muito importante a todos que trabalham com inserção de dados em planilhas.  Em muitos casos ao invés da função retornar um resultado numérico, a célula que contém a fórmula exibe uma mensagem estranha como #N/D#DIV/0! ou #VALOR! Na maioria das vezes deve-se rastrear o erro e corrigi-lo, mas existem casos em que o erro da fórmula significa que os dados utilizados pela função ainda não estão disponíveis. Quando isso acontecer uma opção é corrigir o erro com a Função SEERRO do Excel.



Esta função está disponível a partir do Excel 2007 e não se aplica para as versões anteriores. 

Continue e lendo e aprenda:
  • Como esconder erros no Excel
  • Como usar a fórmula SEERRO no Excel
  • Como corrigir o erro #N/D, #DIV/0! ou #VALOR! no Excel

Melhoria em relação ao Excel 2003

Anteriormente no Excel 2003 a melhor alternativa para tratamento de erros era a utilização da Função ÉERROS aninhada com a Função SE como na seguinte fórmula:

=SE(ÉERROS(PROCV(...));"Não encontrado"; PROCV (...))


A fórmula acima verifica se a Função PROCV retorna um erro e, em caso afirmativo retorna o texto "Não encontrado" senão exibe o resultado da Fórmula PROCV. A partir do Excel 2007 a fórmula acima pode ser escrita com muito mais eficiência e de forma mais clara com a Função SEERRO.

Como funciona a Função SEERRO 

A Função SEERRO verifica se uma expressão ou valor resulta em erro. Se assim for, o resultado será um valor alternativo (valor_se_erro), caso contrário o resultado será a própria expressão

Sintaxe: =SEERRO(valor; valor_se_erro)

  • valor: Pode se referir a uma célula ou fórmula que será testada 
  • valor_se_erro: Valor ou expressão a ser retornada se o argumento inicial retornar um erro 

Como usar a Função SEERRO no Excel

Corrigir um erro no Excel significa dar opções de correções para uma fórmula que inevitavelmente irá retornar um erro como resposta. 

Como corrigir o erro #DIV!. no Excel

No exemplo abaixo a coluna D calcula o percentual que o frete representou em relação ao valor da nota fiscal. A célula D2 contém a fórmula: =C2/B2

Observe que nas linhas onde não existem lançamentos a coluna D retorna o erro #DIV!. No Excel, uma célula vazia como em B5, B6 e B7 é considerado zero, e não é possível dividir um número por zero.

como-corrigir-erros-no-excel


Para corrigir o erro e deixar a planilha mais elegante substitua a fórmula da célula D2 por esta:

=SEERRO(C2/B2;"") e arraste para as outras células da coluna.

O Excel interpreta a fórmula da seguinte forma:

Se houver um erro em C2/B2 deixe a célula vazia (""), caso contrário retorne a divisão de C2/B2.

Agora pratique na planilha do Excel Web App abaixo. Este exemplo utiliza a fórmula PROCV para retornar a descrição do produto que consta em outra tabela. Baseando-se na fórmula da célula E2:

=SEERRO((PROCV(D11;A10:B15;2;0));"")

Corrija as células que estão com o erro #N/D.



Além da exemplo mostrado acima a Função SERRO serve para corrigir todos os erros a seguir:

#DIV/0!. #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME? ou #NULO!.
Qualquer dúvida quanto a resolução do exercício, deixe um comentário que responderei.

Usar a Função SEERRO é muito fácil. Além de prevenir que o Excel impeça a realização de algum cálculo em função de um erro deixa sua planilha muito mais elegante e profissional.

Baixe aqui as planilhas utilizadas neste tutorial

E você, de que forma costuma tratar os erros no Excel? Por favor, compartilhe suas dicas e exemplos conosco usando os comentários.

Se você achou este artigo útil, por favor, compartilhe com seus amigos através das redes sociais abaixo.

É proibido a reprodução parcial ou integral dos artigos deste blog. Copiar na íntegra qualquer conteúdo aqui publicado, implica em crime previsto no Código Penal

Ricardo Fialkoski é o fundador do blog Excel na Web. Trabalha com Excel há mais de dez anos desenvolvendo Soluções Avançadas em Excel e VBA.

Comentário(s):

10 comentários :

  1. Olá, consegue informar o erro dessa formula: =SE(ÉERROS(PROCV(C2;'RELAÇÃO DE NOTIFICAÇÃO'!A6:I8445;2);"";PROCV(C2;'RELAÇÃO DE NOTIFICAÇÃO'!A6:I8445;2)))

    ResponderExcluir
    Respostas
    1. Olá! Existe um erro na abertura e fechamento dos parênteses. Segue a fórmula correta:
      =SE(ÉERROS(PROCV(C2;'RELAÇÃO DE NOTIFICAÇÃO'!A6:I8445;2));"";PROCV(C2;'RELAÇÃO DE NOTIFICAÇÃO'!A6:I8445;2)). Sempre que puder deixe um comentário aqui no blog, combinado? Abraço!

      Excluir
  2. Olá, como faço para a seguinte situação dê certo?

    Na célula CT59 - quero que me dê o resultado de quantos alunos desistentes há de CJ12 até CJ56. Entretanto, se de CJ12 até CJ56 não houver nenhum valor ou não aparecer a palavra "desistente", o excel deixe a célula CT59 em branco, em vez de retornar "0" (zero).

    Tenho feito assim:

    =CONT.SE(CJ12:CM56;"DESISTENTE")

    com "SE", mas não dá certo!

    Existe alguma forma que seja possível executar tal tarefa no excel?

    Obrigado pela atenção.

    ResponderExcluir
  3. Boa noite, você consegue solucionar utilizando Função SE da seguinte forma: =SE(CONT.SE(CJ12:CM56;"DESISTENTE")<1;"";CONT.SE(CJ12:CM56;"DESISTENTE")) As "aspas" dizem ao Excel para "deixar vazio" ao invés de 0. Obrigado pela visita e volte sempre que precisar combinado? Um abraço!

    ResponderExcluir
    Respostas
    1. Obrigado pela ajuda valiosa!

      Tenho um problema aqui com uma fórmula que acho que é impossível resolvê-la.

      O problema é o seguinte...

      Na célula [QY16] quero que o Excel me dê a porcentagem de um aluno em relação a assiduidade dele.

      Para isso sei que para obter essa informação eu tenho que dividir o total de presenças que esse aluno teve com o total de aulas trabalhadas.

      Eu até fiz aqui o que a maioria usaria, mas gostaria que esse cálculo fosse mais direto.

      Tenho usado o seguinte...

      =SE(QU10=0;;CONT.SE(OV16:PP16;"P")/QU10) + CONT.SE(QF16:QT16;"P")/QU10

      Exemplificando:

      >> QU10 – está o total de aulas dadas;

      >> OV16:PP16 – estão as informações de Presenças ou faltas + QF16:QT16, onde estão o outro intervalo das informações de Presenças ou faltas, pois.

      Eu até consegui, em parte, obter a informação de frequência do aluno, mas quando estas células estão vazias o Excel exibi o erro #DIV/0!

      Achei que usando o SE ou SEERRO poderia corrigir este problema.

      Enfim, ou eu estou usando critérios/funções erradas para atingir o meu propósito ou está faltando alguma coisa na(s) fórmulas citadas.

      Por favor, me ajude!

      Obrigado pela atenção!

      Excluir
    2. Boa noite, voce pode usar apenas a Função SEERRO para corrigir a fórmula e eliminar o erro #DIV/0!. Substitua a sua fórmula por esta: =SEERRO((CONT.SE(OV16:PP16;"P")/QU10+CONT.SE(QF16:QT16;"P")/QU10);"")
      Obrigado pela visita! Um abraço!

      Excluir
  4. Bom dia!

    Como fazer para que na fórmula a seguir apareça a mensagem de (PRODUTO NÃO CADASTRADO), quando for digitado um código que não está no banco de dados.

    Segue a fórmula:

    =SE(A2="";"";PROCV(A2;'Banco de dados'!A3:B32;2;0))

    Gostaria de usar a função SEERRO para está fórmula

    ResponderExcluir
    Respostas
    1. Bom dia, nesse para fazer uma mensagem personalizada você precisa usar a Função PROCV com SEERRO da seguinte forma:

      =SE(A2="";"";SEERRO(PROCV(A2;'Banco de dados'!A3:B32;2;0);"PRODUTO NÃO CADASTRADO"))

      Abraços!

      Excluir
  5. Muito obrigado Ricardo, este tutorial é muito bom.

    Abraços

    Agora preciso tirar uma dúvida, antes de receber sua resposta eu refiz a fórmula usando procv + seerro desta forma:
    =SEERRO(PROCV(A2;'Banco de dados'!
    A3:B32;2;0);"Produto não cadastrado")
    Gostaria de saber se dessa forma também está correto.

    ResponderExcluir
    Respostas
    1. Olá Sergio, está correto sim, esta é a maneira correta de como usar Procv com Serro no Excel. Abraço!

      Excluir